2:30 AM MT: The attack has stopped and will continue to co-monitor the situation closely. Thank you for your patience and support during this incident. We will follow-up with any further details and developments, if relevant.
Posted Jul 04, 2025 - 02:30 MDT
Monitoring
2:02 AM Mountain Standard Time: Mitigation efforts continue. Our engineering team currently has the attack mitigated and will continue to monitor. The order form is back to fully operational. Thank you for your patience.
Posted Jul 04, 2025 - 02:04 MDT
Update
We are continuing to investigate this issue.
Posted Jul 04, 2025 - 01:51 MDT
Investigating
1:50 AM Mountain Standard Time: ClickBank is currently experiencing another substantial DDOS attack. We are working with the AWS team to mitigate the attack. There is a potential that some order forms will be intermittently impacted. We will send an additional update within an hour.