Order Form issues

Incident Report for ClickBank

Resolved

The order form issues have been resolved. We are doing an RCA to put additional safeguards in place to prevent additional outages.
Posted Feb 10, 2026 - 10:53 MST

Identified

We are experiencing an order form outage and the team is currently working to correct this quickly.
Posted Feb 10, 2026 - 10:38 MST
This incident affected: Order Form.