PayPal Processing Issue

Incident Report for ClickBank

Resolved

PayPal has notified ClickBank that its payment processing issues have been resolved.
Posted Oct 16, 2025 - 11:52 MDT

Investigating

PayPal is currently experiencing an issue with processing payments. We are rapidly investigating scope and will provide additional details as soon as possible. We will send an update within 30 minutes.
Posted Oct 16, 2025 - 10:29 MDT
This incident affected: Order Form.