Upstream service provider degraded performance affecting credit card acceptance issues
Incident Report for ClickBank
Resolved
This incident has been resolved. The upstream provider and ClickBank will continue to monitor and ensure everything is working as expected.
Posted Jul 18, 2024 - 22:08 MDT
Update
ClickBank’s upstream provider is reliant on Microsoft Azure. Microsoft’s Azure cloud platform is currently encountering an extended outage in the Central US region.

We continue to monitor the situation and expect Microsoft to restore service quickly.

Microsoft will provide updates at this link: https://azure.status.microsoft/en-us/status
Posted Jul 18, 2024 - 19:26 MDT
Update
The provider is continuing to work on the issue. We will provide updates as soon as we know more.
Posted Jul 18, 2024 - 17:49 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2024 - 17:00 MDT
Investigating
We were notified that an upstream issue is causing degraded performance on credit card acceptance. We are investigating and working with the affected service provider currently
Posted Jul 18, 2024 - 16:47 MDT
This incident affected: Order Form.