Intermittent processing issue
Incident Report for ClickBank
Resolved
Our team has identified and implemented a solution to the credit card processing issue, which originated from an upstream provider. All systems and services operational. Credit card orders are processing normally! We are working closely with the provider on root cause analysis. Thank you for your patience and understanding.
Posted Apr 04, 2024 - 14:06 MDT
Investigating
At 1:29PM Mountain Time - ClickBank began experiencing an intermittent issue processing credit card payments. We are working with our merchant processing provider to resolve the issue and will provide regular updates.
Posted Apr 04, 2024 - 13:36 MDT
This incident affected: Order Form.