Degraded Credit Card Processing
Incident Report for ClickBank
Resolved
Credit card processing issues caused by the Crowdstrike/Microsoft outage have been resolved. Credit cards payments are processing normally and as expected. We are actively monitoring performance alongside upstream providers to ensure continued stability. We will provide additional updates if any further information becomes available.
Posted Jul 19, 2024 - 09:39 MDT
Identified
ClickBank continues to accept and process credit card orders, but like many businesses and services around the world, we are still feeling the impact of last night's major Microsoft and Crowdstrike outages.

Although there are system-wide authorization issues with the major banks and card brands, we are monitoring their progress and hope to see them return to full service shortly.

We will continue to update as we learn more.
Posted Jul 19, 2024 - 07:30 MDT
This incident affected: Rebills and Order Form.