Significant DDOS attack

Incident Report for ClickBank

Resolved

1:14 PM MST: Our team has resolved the attack and will continue to monitor the situation closely. Thank you for your patience and support during this incident. We will follow-up with any further details and developments, if relevant.
Posted Jul 04, 2025 - 13:14 MDT

Monitoring

12:53 PM Mountain Standard Time: Our engineering team currently has the attack mitigated and will continue to monitor. The order form is back to fully operational. Thank you for your patience.
Posted Jul 04, 2025 - 12:53 MDT

Investigating

12:31 PM Mountain Standard Time: ClickBank is currently experiencing another substantial DDOS attack. We are working with the AWS team to mitigate the attack. There is a potential that some order forms will be intermittently impacted. We will send an additional update within an hour.
Posted Jul 04, 2025 - 12:32 MDT
This incident affected: Hops and Order Form.