Intermittent Order Form Issues

Incident Report for ClickBank

Postmortem

Valued ClickBank Clients,

Beginning at 5:14 PM ET this afternoon, ClickBank experienced a widely distributed and highly sophisticated denial of service (DDoS) attack against our systems.

Our protections mitigated the majority of the potential problems an attack like this can pose, but we still experienced a bout of intermittent order form loading issues during our resolution action.

Our Engineering teams were able to fully mitigate the attack around 6:12 PM ET.

Although our standing protective systems successfully blocked the bulk of this attack, we rapidly implemented additional protection services to help fully mitigate future attacks, as well.

We appreciate your patience and understanding with issues like this. Rest assured that we are constantly vigilant and on alert to prevent issues of this nature.

Please reach out to your AM next week if you would like to discuss this further.

Thank you.

Posted Apr 18, 2025 - 17:44 MDT

Resolved

Resolved: We have fully resolved the reduced number of intermittent order form performance issues. All systems and services operational. Thank you for your patience and understanding.
Posted Apr 18, 2025 - 16:24 MDT

Update

Although reduced, the ClickBank order form is still experiencing intermittent loading issues for some users. Our engineering team is actively working to restore full performance and stability. We will provide another update as soon as possible.
Posted Apr 18, 2025 - 15:35 MDT

Monitoring

Order form issues have been stabilized and the order form is operational. The team will continue to closely monitor OF performance in the unlikely event of any ongoing issues. We will provide another update if warranted.
Posted Apr 18, 2025 - 15:21 MDT

Investigating

We are currently experiencing an intermittent order form service issue. We are rapidly investigating scope and will provide additional details as soon as possible. We will send an update as soon as possible.
Posted Apr 18, 2025 - 15:07 MDT
This incident affected: Order Form.