Intermittent order form loading issues
Incident Report for ClickBank
Resolved
This issue has been resolved and the order form is loading as normal. Please note this issue was intermittent and the majority of orders were still being processed as normal. This issue started at 3:53PM MST and was resolved at 3:59PM.
Posted Dec 05, 2024 - 16:09 MST
Identified
ClickBank has identified an intermittent issue with order form loading speed. We are currently working on a fix and will update as soon as this issue has been resolved.
Posted Dec 05, 2024 - 16:03 MST
This incident affected: Order Form.