11:30 AM Mountain Time: Working alongside AWS, we have resolved the attack and will continue to co-monitor the situation closely. Thank you for your patience and support during this incident. We will follow-up with any further details and developments, if relevant.
Posted Jun 14, 2025 - 11:31 MDT
Update
10:28AM Mountain Time: While the DDOS attack is still ongoing, ClickBank has successfully scaled a significant amount of hardware and is blocking the overwhelming majority of the attack. We will continue to update you on our progress.
Posted Jun 14, 2025 - 10:30 MDT
Investigating
09:25AM Mountain Time: ClickBank is currently experiencing a substantial DDOS attack. We are rapidly mitigating the attack and will provide additional details as soon as possible. There is a potential that some order forms will be intermittently impacted. We will send an additional update within an hour.