Major Outage

Incident Report for ClickBank

Resolved

Service has been fully restored. Orders are processing as expected and additional services are back online. We will continue monitoring performance to confirm ongoing stability and prevent recurrence. Thank you for your patience and understanding.
Posted Jul 29, 2026 - 15:50 MDT

Update

The issue has been resolved and all services are returning to normal.
Posted Jul 29, 2026 - 15:45 MDT

Update

We have identified the source of the issue and are implementing mitigation measures to reduce customer impact and accelerate service recovery. Thank you for your patience. More info coming soon.
Posted Jul 29, 2026 - 15:39 MDT

Investigating

ClickBank is currently experiencing a major outage affecting access to multiple services, including the order form. Our engineering team is actively investigating the issue to determine root cause and restore normal service as quickly as possible. We will provide another update as quickly as we can.
Posted Jul 29, 2026 - 15:16 MDT
This incident affected: Hops, Order Form, Accounts, INS, API, CLKBank, Website, and Marketplace.